DB settings failed
Incident Report for Scrapbox
Postmortem

Scrapbox was inaccessible for an hour. We apologize for the inconvenience.

What happened

We deployed two at the same time.

  • Code for new features
  • DB index creation code for use in new features

A large number of processes requiring a non-existent DB index were running, and the DB hung up.

Remediation plan

Deploy the code that creates the DB index first.
Then deploy the new functionality.

Posted Mar 06, 2022 - 09:07 UTC

Resolved
This incident has been resolved.
Posted Mar 06, 2022 - 08:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2022 - 08:17 UTC
Update
DB configuration has been modified and is being deployed.
Posted Mar 06, 2022 - 07:56 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 06, 2022 - 07:17 UTC
This incident affected: Scrapbox Server.